• Script Backup Otomatis Konfigurasi MikroTik

    Posted on 1 January 2013 by GmiB26.Net in Tips & Trik, Tutorial.

    Script Backup otomatis Konfigurasi MikrotikScript ini bertujuan untuk membuat backup settingan mikrotik yang nantinya otomatis dikirim ke email sekaligus upload ke server FTP. Script ini bisa juga di gabungkan dengan scheduler sehingga akan berjalan sesuai jadwal. Script backup otomatis ini akan sangat membantu bagi anda yang khawatir terjadi crash pada routerboard atau router mikrotik yang sedang digunakan sehingga saat anda harus mengganti device tersebut anda tinggal merestore ulang dari file backup yang telah dibuat.

    Isi script : ( buka winbox, klik system > Scripts > [+], lalu paste script dibawah pada kolom source, perhatikan parameter bercetak tebal. kemudian klik [OK] untuk save dengan nama BackupSystem)

    #---setting waktu dulu---
    :local ds [/system clock get date]
    :set ds ([:pick $ds 7 11].[:pick $ds 0 3].[:pick $ds 4 6])
    #--setting parameter nama file--
    :local identitas [/system identity get name];
    :local seri [/system resource get board-name];
    :local File ($identitas."-$seri"."-System-".$ds.".backup")
    #--buat file backup---
    /sys backup save name=$File;
    :delay 10s
    :log info "Backup konfigurasi $seri BERHASIL dibuat dengan nama $File "
    #--kirim ke email--
    /tool e-mail send subject=$File body=$File [email protected] tls=yes file=$File
    :log info "File $File dikirim ke email BOS BESAR"
    #--upload ke FTP server--
    :delay 10s
    /tool fetch address=ftpserver.gmib26.net port=2121 src-path=$File user=userftp mode=ftp password=passwordftp dst-path=$File upload=yes;
    :log info "File $File BERHASIL dikirim ke ftpServer.GmiB26.Net via FTP"
    #--biar gak menuh2in RB filenya dihapus--
    :delay 300s
    :if ([:len [/file find name=$File]] > 0) do={/file remove $File}
    :log info "File $File dihapus..!"
    

    Jangan lupa setting email agar script bisa kirim file backup ke email.

    (disini saya menggunakan email yang berbeda provider dengan alamat “to” pada script biar bisa simpen filenya di dua tempat sekaligus)

    SMTP yang saya gunakan adalah smtp.gmail.com silahkan liat ipnya di cmd windows dengan perintah nslookup smtp.gmail.com misal didapat ip 209.85.225.109

    
    /tool e-mail set server=209.85.225.109 port=587 from="MIKROTIK" user=usergmail password=passwordgmail tls=yes
    


    Selanjutnya set scheduler agar script di eksekusi sesuai jadwal yang mbah2 inginkan :

    klik menu System > Scheduler > [+]

    ubah start time sesuai waktu yang mbah2 inginkan misal 23:59:59

    Kenudian ubah interval script mau dieksekusi misal tiap 7 hari sekali maka isi 7d 00:00:00

    lalu isi kolom on event dengan nama script yang tadi di save disni saya pakai BackupSystem

    klik [OK]

     

    Selamat mencoba, mohon koreksi kalau ada yg salah.

     

    Script ini pernah diposting pada Group FB Komunitas All About RT/RW-Net KasKus

     

    GmiB26.Net – Your Computer and Network Solution

    GmiB26.Net berlokasi di Perumahan Griya Mangli Indah B.26 kaliwates, Jember – JATIM. Bergerak dibidang Komputer dan Jaringan, Internet Unlimited via HotSpotLayanan Hosting dan Pendaftaran/Registrasi Domain Murah, Penjualan Pulsa All Operator dan Pembayaran Tagihan Online (PPOB)

    Post Tagged with ,
Tell Your Friends About This Page!
upon digg

Leave a Reply

Your email address will not be published. Required fields are marked *

Your ip address : 54.167.112.42
Current Time : 19 November 2018 14:23:19 GMT+7